Targus Validates DisplayLink® v1.2 for Ubuntu Linux

- Posted in:
Targus Validates DisplayLink® v1.2 for Ubuntu Linux | Tech Talk | Discover Targus Blog
LinuxThis release has been prepared to be compatible with Ubuntu 14.04.x LTS and 16.04 LTS. Other variants and editions may be compatible if they meet minimum O/S requirements, but are not supported. The full release notes are shown here. We have validated this version with Targus Universal Docking Stations (UDS). Upgrade Instructions Uninstall the current DisplayLink Ubuntu driver with the following command on a Terminal and then follow the Installation Instructions below. sudo displaylink-installer uninstall Installation Instructions
  1. Extract the .run file from the .zip file.
  2. Make the .run file executable by right clicking on the file and choose "Properties". propertiesCheck the "Allow executing file as a program" box.
  3. Install the DKMS framework from a Terminal using the command sudo apt-get install dkmsdkms
  4. Execute the DisplayLink .run file using the Terminal, by cding to the directory containing the .run file and running the command sudo ./displaylink-driver-1.2.58.run (where xxxx is the version number)
  5. The DisplayLink software should install as shown below. Install DL.png
  6. You can now connect and may need to reconnect your DisplayLink products to the computer.

Subscribe to the Discover Targus blog

Select the blog(s) you would like to subscribe to: